Release Notes

Aus Recorder-Wiki
Wechseln zu: Navigation, Suche

Recorder 6.22.1

Veröffentlicht im März 2014 (GB) / Januar 2015 (D)

Wesentliche Optimierungen in Recorder 6.22 beziehen sich auf den Import Assistenten

  • Der Import-Assistent wurde so geändert, dass Beobachtungen importiert werden können, ohne dass Beobachter zugeordnet werden müssen.
    Daten, die auf diese Weise importiert werden, entsprechen jedoch nicht Recorder-Standards, daher werden sie als temporär eingestuft und können nicht exportiert werden. Um Daten auf diese Weise zu importieren, erstellen Sie zunächst ein Projekt, bei dem der Medien-Eintrag auf 'Temporär' gesetzt ist, und wählen Sie dieses Projekt aus, wenn Sie die temporären Daten importieren. Wenn Sie beim Import die Spalten zuordnen, werden Sie feststellen, dass TempObserver(s) anstelle von Kartierern verfügbar ist.
    TempObserver(s) werden beim Import nicht mit Personen aus dem Namens- und Adressenmodul abgeglichen und zugeordnet, so dass die einzelnen Beobachter (Kartierer) nicht als Kartierer in einem Begang und in einer Aufnahme gespeichert werden können. Sie werden ausschließlich zum Begang in einem nicht standardmäßig abfragbaren Feld "Recorders" abgelegt. Sie werden auch nicht in den Details der Beobachtungs-Hierachie angezeigt, stattdessen wird "unterdrückt/withheld" angezeigt.
    Weiterführende Informationen finden Sie in der Hilfe unter Importing Temporary Data (englisch).
  • Der Import-Assistent wurde so angepasst, dass einige Spalten Schlüsselwerte anstelle von Zeichenfolgen enthalten können.
    Weiterführende Informationen finden Sie in der Hilfe unter Import Wizard - data format, Supported columns :
    • Anstelle des Sippennamens, kann diese entsprechende Spalte den Recorder internen Schlüsselwert für die Art (taxon_version_key) enthalten. Dies ist dann nützlich, wenn die Software, die die Daten exportiert, diese Schlüssel bereit stellen kann.
    • Anstelle des Namens des bzw. der Kartierer, kann die entsprechende Spalte die Recorder eigenen Schlüssel für die Person (indivudal_key) enthalten.
    • Anstelle des Fundortes kann die entsprechende Import-Spate den Recorder internen Schlüssel des Fundortes (location_key) enthalten.
  • Der Import-Assistent importiert Externe Schlüssel (external keys) - siehe in der englischen Hilfe Import Wizard - data format, Supported columns
  • Im Beobachtungsbaum können Autoren von Sippennamen anzeigt werden. Dazu muss unter Extras > Optionen, Reiter Allgemein unter Anzeige Sippennamen die Option Autoren eingeschaltet sein..
  • Wenn an gleicher Stelle die Option Originalnamen ausgewählt ist, werden im Beobachtungsbaum die Namen der Sippen zusätzlich zu den bevorzugten ("gültigen") Sippennamen mit den eingegebenen Namen angezeigt.
  • Attribute zu Sippennamen werden im Beobachtungsbau angezeigt, sofern vorhanden.
  • Beim Export von Berichtsergebnissen in andere Formate ist es jetzt möglich, Berichtsvorlagen bzw. Spezifikationen die beim Export erstellt wurden für die spätere Wiederverwendung im Ordner für Exportvorlagen abzulegen. Dieser kann unter unter Extras > Optionen, Reiter Dateispeicherorte individuell festgelegt werden..
  • Diverse Attribute wurden im Report-Assistenten dem Bereich Sippen hinzugefügt:
    • Empfohlener Sippenname/Attribut kein Subgen.
    • Empfohlener Sippenname/Attribut
    • Wissenschaftl. Name/Attribute kein Subgen.
    • Wissenschaftl. Name/Attribute
    • Sippenname Attribute
    • Wissenschaftl. Name Attribute
    • Empfohlener Name Attribute
    • Vollständiger Empfohlener Name

Recorder 6.23.2

Veröffentlicht im Juli 2015 (GB) / Dezember 2015 (D)

  • Weitere Optionen stehen beim Datenexport zur Verfügung:
    • Nutzer können die Neuzuordnung des Datenbesitzer ("Custodian") für einzelne Tabellen festlegen
    • Standardmäßig wird der Datenbesitz in einer Tabelle nur den geändert, wenn alle Datensätze in abhängigen Tabellen (child tables related to it) exportiert und geändert wurden. Um den Datenbesitz (custodian) von Einzeldatensätzen (nicht ganzen Datenbeständen), die exportiert wurden ebenfalls zu ändern, muss die Option Change partially exported ausgewählt werden.
    • Nicht gültige (invalid) Einträge können jetzt ebenfalls exportiert werden.
  • Private Daten
    Manchmal ist es hilfreich neben den allgemeinen Informationen über den Beobachtungsort auch eher private Informationen, wie beispielsweise eine Hausnummer, abzulegen, die zwar abgefragt werden können, auf die der Zugriff stärker eingeschränkt sein soll. Auf der Ebene der Aufnahmen wurde deswegen ein Tab Vertrauliche Daten ergänzt. Dort können in den zwei Feldern Vertrauliche Örtlichkeit und Vertraulicher Code als vertraulich angesehene Informationen abgelegt werden. Diese Felder sind einfache Zeichenfolgefelder, in denen jedwede Information abgelegt werden kann. Sie können über den Importassistenten importiert werden und können bei Bedarf in Berichte aufgenommen werden.
    Standardmäßig werden sie nicht exportiert, in Version 6.25 wurde eine Option hinzugefügt, um sie in Exporte aufnehmen zu können.
  • Der Schlüsselwert des Aufnahme Fundorts wurde im Berichts-Assistenten im Bereich Metadaten ergänzt.
  • In Deutschland häufig genutzte Kartierraster sowie das Europaweite Inspire Raster können als zusätzliche Spalte einem Bericht hinzugefügt werden werden. Sie können im Auswahlbaum unter Aufnahmen > Rasterfelder ausgewählt werden. Die mit WKT gekennzeichneten Rasterfelder werden als Geoobjekt im Well-Known-Text-Format exportiert.Im Einzelnen stehen folgende Rasterfelder zur Verfügung:
    • Minutenfeld (QYX)
    • MTB
    • Quadrant (MTBQ)
    • 1/4tel-Quadrant (MTBQQ)
    • INSPIRE 10 km (INSP 10K)
    • INSPIRE 5 km (INSP 5K)
    • INSPIRE 10 km (INSP 10K WKT)
    • INSPIRE 5 km (INSP 5K WKT)


  • Es ist jetzt möglich, individuell Eingabeformulare für die Eingabe von Einzelbeobachtungen zu erstellen. Dazu muss eine XML-Datei erstellt werden, in der die Struktur des Eingabeformulars festgelegt wird. Die Datei muss im Ordner "Custom Species Cards" unterhalb der "User Files" abgelegt sein. Das Eingabeformular seht nach dem Neustart vor Recorder unter Dateieingabe>Benutzerdefinierte Sippeneingaben>"Name des Formulars" zur Verfügung.

Recorder 6.24.1

Veröffentlicht Oktober 2015 (GB) / Januar 2016 (D)

  • Erkennen und analysieren von Beobachternamen im Import Assistenten wurde weiter optimiert. Bei der Vielfalt unterschiedlicher Möglichkeiten Vornamen, Familienname, Titel, Anreden und deren Kürzel zu kombinieren kann jedoch keine für alle Fälle korrekte Erkennung einzelner Beobachter erreicht werden. Deswegen wird weiterhin empfohlen Namen von Beobachtern (oder Kartierern) vor dem Import zu standardisieren.
  • Im Namen- und Adressmodul ist es jetzt möglich, den Todestag einer Person auch dann einzugeben, wenn deren Geburtsdatum unbekannt ist. In diesem Fall muss Unbekannt als Geburtsdatum eingegeben werden, bevor man das Sterbedatum eingibt.

Recorder 6.25.1

Veröffentlicht Juni 2016 (GB) / Januar 2017 (D)

Wesentliche Änderungen und Optimierungen in Recorder 6.25.1

  • Der Passwort-Hinweis für neue Nutzer, die zum ersten Mal Recorder öffnen, wurde neu verfasst und übersetzt, um eindeutiger zu sein.
  • Im Hilfe-Menü wird jetzt sowohl die aktuelle Datenbank-Version als auch die von Recorder selbst dargestellt. Dazu werden die Nummern der jeweils letzten Upgrade-Sequenzen genannt.
  • Die Recorder-Hilfe im englischsprachigen Original ist jetzt Online verfügbar. Sie können sie aus Recorder heraus über Hilfe>Online-Hilfe aufrufen.
  • Die Darstellung in den Hierarchiebäumen der Module Orte, Namen und Adressen und Beobachtungen wurde revidiert
    • In Orte-Modul werden Fundorte jetzt nach präferiertem Fundort und nicht präferiertem Fundort mit unterschiedlich Symbolen dargestellt. Das hat keine direkten Auswirkungen auf die Auswahl, kann jedoch bei eine umfangreichen Fundortliste die Auswahl erleichtern.
    • Das Gleiche gilt auch für das Namen- und Addressen-Modul
    • Im Beobachtungsbaum wird über unterschiedliche Symbol-Bilder vor einer Beobachtung dargestellt, wie der Status ihrer Verifizierung ist, ob sie vertraulich ist und ob es sich um einen Null-Nachweis handelt.
    • Wer die alte Symbolik bevorzugt, kann dies unter Tools>Optionen, Tab. Erscheinungsbild zurücksetzen.
  • Der Nutzer kann jetzt die Sortierreihen in der die Projekt-Tags (Schlagworte) im Beobachtungsbaum erscheinen selber festlegen. Dazu steht jetzt unter Extras>Erweiterte Referenzlisten der Eintrag Sortierschlüssel zur Verfügung.
  • Bei der Neuanlage oder Änderung eines Projektes sind Begrenzungsrahmen oder Erfassungsbereich des Projektes nur mehr fakultativ.
  • Wenn Begänge und Aufnahmen einen Fundortnamen, aber keinen verknüpften Fundort haben, werden jetzt Fundortname und Raumreferenz im Beobachtungsbaum angezeigt.
  • Zahlreiche Optimierungen und Änderungen betreffen den Import-Assistenten:
    • Eine Beobachtung mit einer Fundortangabe kann jetzt auch ohne Raumbezug importiert werden. Wenn die Fundortangabe einem Fundort aus der (Fund-)Ort-Datenbank zugeordnet wird, wird dessen Zentralkoordinate übernommen und als Raumreferenz für Aufnahme- und Begang eingetragen. Wird kein Fundort zugeordnet, wird der Fundort der Import-Datei in den Fundortnamen übernommen, die Raumreferenz in Begang und Aufnahme bleiben leer.
    • In der Fundortspalte der Import-Datei sind leere Einträge nun erlaubt.
    • Ist ein Raumreferenzsystem angegeben, muss es für jede Beobachtung angegeben werden, ebenso wie der Raumbezug (Koordinate oder Raster)
    • Wenn die Importdatei eine Spalte Bestimmernamen (Determiner Name) enthält, werden die dort vorhandenen Einträge genau so wie die der Spalte Beobachter (oder Kartierer) analysiert. Werden mehrere Namen erkannt, wird nur der erste übernommen und die anderen verworfen.
    • Zu Ende eines Importprozesses besteht nun die Möglichkeit eine Filterdatei der importierten Einträge abzuspeichern. Diese Option findet sich unter dem Tab "Ungültige Einträge" Es hat sich als sehr hilfreich erwiesen, diese Filterdatei zu besitzen, wenn um Probleme, die bei den Import aufgetreten sind später über die Batch Update- und Report Funktionalitäten zu analysieren und zu lösen. Die Filterdatei wird standardmäßig immer gespeichert, es sei den der Nutzer widerspricht dem ausdrücklich.
    • Die Option, die alte Importfunktionalität zu nutzen, wurde entfernt.
  • Die zusätzlichen Filter im Bericht-Assistenten wurden um folgende Einträge ergänzt:
    • Geobasiseintrag (Naturraum, Admin. Einheit)
    • Associate (Name or Key)
    • Aufnahme, vertraul. Code
    • Aufnahme, vertraul. Örtlichkeit
    • Projektstatus